Whoops! WordPress Plugin Update Issue

Posted by Cyn | Posted in Blogging, Geekery | Posted on 13-04-2008

6

One of the neat things about Word­Press 2.5 is that when a plu­g­in that’s in the Word­Press Plu­g­in Direc­to­ry is updat­ed, you get a mes­sage ask­ing if you want to down­load the new ver­sion or upgrade auto­mat­i­cal­ly. If you use the auto­mat­ic option, Word­Press down­loads the new ver­sion, deletes the old one, unzips the down­loaded file, and reac­ti­vates the plu­g­in. It’s mar­velous­ly sim­ple, com­pared to down­load­ing, unzip­ping, delet­ing, upload­ing, and reac­ti­vat­ing things man­u­al­ly. Until last night, it worked beau­ti­ful­ly.

Gravatars and Plugins and WordPress, Oh My!

Posted by Cyn | Posted in Blogging, Geekery | Posted on 05-04-2008

8

Since Word­Press 2.5 has Gra­vatar sup­port, I’m attempt­ing to add Gra­vatars to my blog tem­plate. Unfor­tu­nate­ly, I just keep get­ting errors, or a the default “no Gra­vatars” image (even for com­ment authors who I know have Gra­vatars, like me). I’m cer­tain that the author of this tem­plate isn’t going to update it to include sup­port, because her web site and busi­ness are up for sale. She has­n’t ever respond­ed to ques­tions in the past, either, so I fig­ure it’s sil­ly to look for help there.

I tried on anoth­er tem­plate, with the same errors. I real­ly don’t want to switch themes again, because I could­n’t even start to remem­ber every­thing I’ve cus­tomized in this one, and I’d rather not do it all over again. I’m annoyed, though. If any­one can help me, I’d appre­ci­ate it!

Update: Squee! They’re work­ing now! The clue I need­ed was in a post at Weblog Tools Col­lec­tion. Now I can try updat­ing the oth­er blogs!

Oth­er­wise, Now Read­ing is work­ing now, thanks to help from the author. I’m thrilled, as it’s one of my favorite plug-ins. When I get Read­er­Ware set up for us again, I’ll try to fig­ure out a way to export data from it to NR.

Cys­tats is not work­ing, though. I did­n’t even real­ize that it was bro­ken at first, because the error only shows up for users who aren’t logged in. Odd­ly enough, it works on some blogs that are run­ning 2.5, but not this one. The author of that plug-in has­n’t respond­ed to my ques­tions, though. It might be due to a lan­guage bar­ri­er, as his blog is writ­ten in Ger­man. Now it’s work­ing again, as ran­dom­ly as it quit work­ing. Why? Who knows? If you see an error on the site at any time, please com­ment and let me know!

I just real­ized that Live­jour­nal Cross­post also died in the upgrade. For­tu­nate­ly, there’s a fix described in the issues board at the devel­op­ment site that should make it work again.

Now I get to go back and see how many posts did­n’t go to LJ, and try to fix that lit­tle omis­sion.